Next: , Previous: , Up: The Macros  


ax_lib_xml_security

Synopsis

AX_LIB_XML_SECURITY([MINIMUM-VERSION])

Description

This macro provides tests of availability of Apache Xml-Security C++ library <http://santuario.apache.org/index.html> of particular version or newer. This macros checks for Apache Xml-Security C++ headers and libraries and defines compilation flags

Macro supports following options and their values:

1) Single-option usage:

   --with-xml-security - yes, no or path to Xml-Security installation prefix

2) Three-options usage (all options are required):

  --with-xml-security=yes
  --with-xml-security-inc - path to base directory with Xml-Security headers
  --with-xml-security-lib - linker flags for Xml-Security

This macro calls:

  AC_SUBST(XML_SECURITY_CFLAGS)
  AC_SUBST(XML_SECURITY_LDFLAGS)
  AC_SUBST(XML_SECURITY_VERSION) - only if version requirement is used

And sets:

  HAVE_XML_SECURITY

Source Code

Download the latest version of ax_lib_xml_security.m4 or browse the macro’s revision history.

License

Copyright © 2008 Alexander Petry petry@itwm.fhg.de
Copyright © 2008 Mateusz Loskot mateusz@loskot.net

Copying and distribution of this file, with or without modification, are permitted in any medium without royalty provided the copyright notice and this notice are preserved. This file is offered as-is, without any warranty.