Next: , Previous: , Up: The Macros  





Makes sure that guile supports the version indicated. If true the shell commands in ACTION-IF-TRUE are executed. If not the shell commands in ACTION-IF-FALSE are run. Note if $GUILE is not set (for example by running AC_CHECK_PROG or AC_PATH_PROG) the macro will fail.


  AC_PROG_GUILE_VERSION([1.6.0],[ ... ],[ ... ])

This will check to make sure that the guile you have supports at least version 1.6.0.

NOTE: This macro uses the $GUILE variable to perform the check. AX_WITH_GUILE can be used to set that variable prior to running this macro. The $GUILE_VERSION variable will be valorized with the detected version.

Source Code

Download the latest version of ax_prog_guile_version.m4 or browse the macro’s revision history.


Copyright © 2009 Francesco Salvestrini

Copying and distribution of this file, with or without modification, are permitted in any medium without royalty provided the copyright notice and this notice are preserved. This file is offered as-is, without any warranty.