Previous: Installation, Up: Installation

2.1 Gnatsweb and gnats do not like each other.

Q: I have installed gnats 3.999.x and Gnatsweb 2.9.x, and I cannot get them work together.

Symptoms are that "make test" fails; if Gnatsweb is installed nevertheless, it hangs when trying to login into the gnats server.

A: The versions are incompatible. Gnatsweb 2.9.x is for use with gnats 3.113.1. With gnats 3.999.x, you must use Gnatsweb 3.99.x; it is in the contrib subdirectory of the gnats distribution. (gnats 3.999.x/Gnatsweb 3.99.x were pre-releases of the 4.0 releases. As 4.0 is out now, you may consider to upgrade to the non-pre versions.)

For gnats 4.x, use Gnatsweb 4.0 or greater.