GNUstep Downloads

We recommend that you check the software versions currently installed on your system. The GNUstep Startup package will do this for you automatically. Then consult the following tables to determine which items need installing or updating. To download the recommended version of any item of software, click on the version number in the appropriate column.

For further information on any particular package, click on its name.

All GNUstep users should install the following items. Choose either the GNUstep Startup package, which combines all four core packages (plus ffcall) or download and install the four core packages separately. (see Installation Docs or the somewhat out-of-date Building GNUstep in Build Guide)

Sources Required? Stable Unstable Notes
GNUstep Startup Required ">0.32.0 none Easy Install Core Packages
GNUstep Make Required ">2.6.6 - Makefile Package
GNUstep Base Required ">1.24.7 - Foundation
GNUstep GUI Required ">0.24.0 - Graphical user interface class library
GNUstep Backend Required ">0.24.0 - Generic back-end

These libraries and tools offer additional capabilities. Some packages and applications may require you to install these libraries

Sources Required? Stable Unstable Notes
GNUstep CoreBase Optional ">0.1
from svn
Core Foundation
Renaissance Optional
-
from svn
Multi-platform UI layout
GNUstep Guile Unsupported ">1.1.4
-
Requires OLD versions of GNUstep and Guile to build/run
StepTalk Unsupported ">0.10.0
-
Scripting language support
JIGS Optional 1.5.5
-
Java bridge
RIGS Unsupported ">0.2.2
-
Ruby bridge
gdl2 Optional
-
">0.10.1 Database Support Library
SQLClient Optional ">1.8.1 from svn Simple Objective-C Interface to SQL databases
WebServer Optional ">1.5.3 from svn Simple web server for applications
WebServices Optional ">0.7.2 from svn Classes for building web services (partial)
Performance Optional ">0.5.0 from svn Performance improvement and measuring classes
Pantomime Optional 1.1.0 1.2.0pre3 GNUMail framework - see also description
PPDs Optional ">1.0.0 - Printer PPDs formerly in gnustep-gui
EnterpriseControlConfigurationLogging Optional ">1.1.3 from svn Classes for building and administering 24*7 server processes for large scale software systemd.

GNUstep Development Tools

If you intend to develop software for GNUstep, or to port software to GNUstep from another environment, you should install the development tools that are relevant to you from the following list:

Sources Required? Stable Unstable Notes
Gorm Recommended ">1.2.18
-
Graphical interface builder
Project Center Recommended ">0.6.2
-
Project developer
nib2gmodel Obsolete ">0.11.0
-
Converts older (pre-10.2 nibs)
OpenStep 2GNU Converter Obsolete ">20000717
-
Older PB Project converter
Examples Optional ">1.4.0
-
GUI examples

GNUstep User Environment

If you intend to use GNUstep to manage files, run applications and so on, please install the items you require from the following list:

Sources Required? Stable Unstable Notes
GWorkspace Recommended ">0.9.2 - File manager for GNUstep
RPM Inspector Optional RPM Viewer
-
GWorkspace inspector for RPM packages
App Wrappers Optional Wrappers
-
Additional GWorkspace wrappers
GNUMail Optional 1.1.0pre2 - GNU Mail - see also description
GNUstep Apps Optional ">Various
-
Other User Applications

Pre-requisites

Please ensure you have at least the Minimum version req'd of each of the following (where needed) on you system, before you install GNUstep. If you need to obtain the software, we suggest that you download the Recommended version.

Sources Required? Minimum
version
req'd
Recom-
mended
version
Notes
make Required 3.75 current GNU make
binutils Depends on OS 2.9.6 current GNU binutils
iconv If no glibc 1.7 current Convert file encoding
clang Recommended 3.3 current Objective-C Compiler supporting modern 2.0 runtime
gcc Optional 2.95.3 current GNU C & Objective-C Compiler
libffi Required 3.0.9 3.0.13 Message forwarding
ffcall Optional 1.8 1.10 Possible alternative to libffi
gmp Optional 3.1.1 current Arbitrary precision arithmetic
guile For guile scripting 1.4 current Scheme language interpreter
openssl Recommended 0.9.6b current SSL and TSL support
libtiff Required 3.4036 current TIFF image support
libpng Recommended - - PNG image support
libjpeg Recommended - - JPEG image support
libxml Required 2.3.0 current For XML property lists and docs
audiofile Recommended 0.2.3 current Program interface to digital audio formats
WindowMaker Recommended 0.92.0
-
Window manager & desktop
libobjc2 Recommended ">1.7
-
Modern ObjectiveC-2.0 support
libobjc Required for MinGW/Cygwin, recommended pre gcc4.6 ">1.7.2
-
Updated libobjc for some systems.

Contact: webmasters@gnustep.org