1 Installation Requirements

Please note that the information on this page may be out of date. Check for the latest installation information on the Mailman wiki.

GNU Mailman works on most POSIX-based systems such as Unix, MacOSX, or GNU/Linux. It does not currently work on Windows. You must have a mail server that you can send messages to, and a web server that supports the CGI/1.1 API. Apache makes a fine choice for web server, and mail servers such as Postfix, Exim, Sendmail, and qmail should work just fine.

To install Mailman from source, you will need an ANSI C compiler to build Mailman's security wrappers. The GNU C compiler gcc works well.

You must have the Python interpreter installed somewhere on your system. As of this writing, Python 2.4.4 is recommended, but see the wiki page above for the latest information.

ll