Next: , Previous: View Menu, Up: Menus

3.4 Mode Menu

Machine White
Tells the chess engine to play White. The Ctrl-W key is a keyboard equivalent.
Machine Black
Tells the chess engine to play Black. The Ctrl-B key is a keyboard equivalent.
Two Machines
Plays a game between two chess engines. The Ctrl-T key is a keyboard equivalent.
Analysis Mode
XBoard tells the chess engine to start analyzing the current game/position and shows you the analysis as you move pieces around. The Ctrl-A key is a keyboard equivalent. Note: Some chess engines do not support Analysis mode.

To set up a position to analyze, you do the following:

1. Select Edit Position from the Mode Menu

2. Set up the position. Use the middle and right buttons to bring up the white and black piece menus.

3. When you are finished, click on either the Black or White clock to tell XBoard which side moves first.

4. Select Analysis Mode from the Mode Menu to start the analysis.

You can now play legal moves to create follow-up positions for the engine to analyze, while the moves will be remembered as a stored game, and then step backward through this game to take the moves back. Note that you can also click on the clocks to set the opposite side to move (adding a so-called ‘null move’ to the game).

You can also tell the engine to exclude some moves from analysis. (Engines that do not support the exclude-moves feature will ignore this, however.) The general way to do this is to play the move you want to exclude starting with a double click on the piece. When you use drag-drop moving, the piece you grab with a double click will also remain on its square, to show you that you are not really making the move, but just forbid it from the current position. Playing a thus excluded move a second time will include it again. Excluded moves will be listed as text in a header line in the Engine Output window, and you can also re-include them by right-clicking them there. This header line will also contain the words 'best' and 'tail'; right-clicking those will exclude the currently best move, or all moves not explicitly listed in the header line. Once you leave the current position all memory of excluded moves will be lost when you return there.

Selecting this menu item while already in ‘Analysis Mode’ will toggle the participation of the second engine in the analysis. The output of this engine will then be shown in the lower pane of the Engine Output window. The analysis function can also be used when observing games on an ICS with an engine loaded (zippy mode); the engine then will analyse the positions as they occur in the observed game.

Analyze Game
This option subjects the currently loaded game to automatic analysis by the loaded engine. The Ctrl-G key is a keyboard equivalent. XBoard will start auto-playing the game from the currently displayed position, while the engine is analyzing the current position. The game will be annotated with the results of these analyses. In particlar, the score and depth will be added as a comment, and the PV will be added as a variation.

Normally the analysis would stop after reaching the end of the game. But when a game is loaded from a multi-game file while ‘Analyze Game’ was already switched on, the analysis will continue with the next game in the file until the end of the file is reached (or you switch to another mode).

The time the engine spends on analyzing each move can be controlled through the command-line option ‘-timeDelay’, which can also be set from the ‘Load Game Options’ menu dialog. Note: Some chess engines do not support Analysis mode.

Edit Game
Duplicate of the item in the Edit menu. Note that ‘Edit Game’ is the idle mode of XBoard, and can be used to get you out of other modes. E.g. to stop analyzing, stop a game between two engines or stop editing a position.
Edit Position
Duplicate of the item in the Edit menu.
Training mode lets you interactively guess the moves of a game for one of the players. You guess the next move of the game by playing the move on the board. If the move played matches the next move of the game, the move is accepted and the opponent's response is auto-played. If the move played is incorrect, an error message is displayed. You can select this mode only while loading a game (that is, after selecting ‘Load Game’ from the File menu). While XBoard is in ‘Training’ mode, the navigation buttons are disabled.
ICS Client
This is the normal mode when XBoard is connected to a chess server. If you have moved into Edit Game or Edit Position mode, you can select this option to get out.

To use xboard in ICS mode, run it in the foreground with the -ics option, and use the terminal you started it from to type commands and receive text responses from the chess server. See Chess Servers below for more information.

XBoard activates some special position/game editing features when you use the examine or bsetup commands on ICS and you have ‘ICS Client’ selected on the Mode menu. First, you can issue the ICS position-editing commands with the mouse. Move pieces by dragging with mouse button 1. To drop a new piece on a square, press mouse button 2 or 3 over the square. This brings up a menu of white pieces (button 2) or black pieces (button 3). Additional menu choices let you empty the square or clear the board. Click on the White or Black clock to set the side to play. You cannot set the side to play or drag pieces to arbitrary squares while examining on ICC, but you can do so in bsetup mode on FICS. In addition, the menu commands ‘Forward’, ‘Backward’, ‘Pause’, and ‘Stop Examining’ have special functions in this mode; see below.

Machine Match
Starts a match between two chess programs, with a number of games and other parameters set through the ‘Match Options’ menu dialog. When a match is already running, selecting this item will make XBoard drop out of match mode after the current game finishes.
Pauses updates to the board, and if you are playing against a chess engine, also pauses your clock. To continue, select ‘Pause’ again, and the display will automatically update to the latest position. The ‘P’ button and keyboard Pause key are equivalents.

If you select Pause when you are playing against a chess engine and it is not your move, the chess engine's clock will continue to run and it will eventually make a move, at which point both clocks will stop. Since board updates are paused, however, you will not see the move until you exit from Pause mode (or select Forward). This behavior is meant to simulate adjournment with a sealed move.

If you select Pause while you are observing or examining a game on a chess server, you can step backward and forward in the current history of the examined game without affecting the other observers and examiners, and without having your display jump forward to the latest position each time a move is made. Select Pause again to reconnect yourself to the current state of the game on ICS.

If you select ‘Pause’ while you are loading a game, the game stops loading. You can load more moves manually by selecting ‘Forward’, or resume automatic loading by selecting ‘Pause’ again.