Further information may still be found on http://www.nongnu.org/thug/gnumach_hardware.html and could perhaps be incorporated into that page. --tschwinge


IRC, freenode, #hurd, 2011-07-24

<braunr> youpi: concerning the ide compatibility problem, it seems some
  bioses provide several modes
<braunr> youpi: "legacy ide" and "native ide"
<braunr> i don't know what native ide really means, but when debugging ide
  probing in gnumach, it just looks like there is nothing to detect
<braunr> and even in this mode, linux uses the ahci driver
<youpi> apparently native means it still uses the IDE protocol, but
  possibly with other IRQs
<youpi> i.e. you need a PCI driver to handle that
<braunr> ok

IRC, freenode, #hurd, 2014-03-02

<teythoon> i bought a new mainboard for my hurd box
<teythoon> a ga-e350n
<teythoon> everything looks fine, grub loads gnumach, and, (afaict) it
  starts it, but i see no single line printed by gnumach
<teythoon> the thing is, that this is the second board of this kind that i
<teythoon> and on the first one, gnumach did work just fine
<teythoon> i tried it with a live cd, the same cd worked on the first
  board, but does not on the second
<teythoon> also, i'm kind of surprised to see nothing at all from gnumach
<teythoon> i mean, it's loaded by grub
<youpi> teythoon: you could try to put *(char*)0xb8000 = 'X' starting from
<youpi> just to see at least something
<teythoon> i'll try, thanks :)